Warning: Attempt to read property "comment_count" on null in /home/host1362995/kali.org.ru/htdocs/www/wp-includes/general-template.php on line 3194
Warning: Attempt to read property "ID" on null in /home/host1362995/kali.org.ru/htdocs/www/wp-includes/post-template.php on line 674

Warning: Attempt to read property "post_type" on null in /home/host1362995/kali.org.ru/htdocs/www/wp-includes/post-template.php on line 675

Warning: Attempt to read property "post_parent" on null in /home/host1362995/kali.org.ru/htdocs/www/wp-includes/post-template.php on line 728
class="-template-default page page-id- page-parent wp-embed-responsive global-layout-right-sidebar wpf-default wpft-post wpf-guest wpfu-group-4 wpf-theme-2022 wpf-is_standalone-1 wpf-boardid-0 is_wpforo_page-1 is_wpforo_url-1 is_wpforo_shortcode_page-0 wpforo">
Уведомления
Очистить все

Проблемы с Parallels, Kali, Macbook M1, Wine одновременно

2 Записи
2 Пользователи
0 Likes
3,128 Просмотры
(@suvorovite09)
New Member
Присоединился: 3 года назад
Записи: 1
Создатель темы  

Всех приветствую. Итак, проблема такова: начал извращаться с Parallels, M1 и Kali. Теперь необходимо запустить Wine для пользования определёнными абсолютно виндовыми программами, но при установке постоянно вылетает error Code (1)

Буду весьма благодарен, если поможете разобраться


   
Цитата
 MiAl
(@mial)
Участник Admin
Присоединился: 6 лет назад
Записи: 267
 

Приветствую! Ничего не понятно из начального сообщения…

Итак, проблема такова: начал извращаться с Parallels, M1 и Kali.

Если есть Parallels, то в нём запускаете Windows, а в ней запускаете приложения под Windows.

Или вы в Parallels запускаете Kali? Для Kali Linux на официальном сайте есть версия под M1.

Если есть Parallels, то, надо полагать, есть и Mac. Существует CrossOver Mac – платная альтернатива Parallels, но подешевле и не всё работает. Но M1 официально поддерживает.

Что касается Wine для ARM… Если вспомнить, что Wine это всё-таки не эмулятор, то можно догадаться, что Wine на ARM это всегда было для тех, кто любит боль. Все говорят, что полученный результат не стоит страданий.

Что касается Wine для ARM который M1… Для любой поддержки M1 нужен wine-6.1. Инструкция по установке и скомпилированные пакеты для Mac есть тут: https://github.com/Gcenx/macOS_Wine_builds . Работает только wine64 через Rosetta2. То есть поддерживаются только 64-битные приложения Windows через Wine который через Rosetta2...

Теперь необходимо запустить Wine для пользования определёнными абсолютно виндовыми программами, но при установке постоянно вылетает error Code (1)

Ничего непонятно — как устанавливаете, хотя бы в какую ОС??? Какая программа выдаёт эту ошибку? на apt не похоже.

 

 


   
ОтветитьЦитата
Поделиться: